Overview of the jose CLI utility
masterThe jose command-line utility is a C-language implementation of the Javascript Object Signing and Encryption (JOSE) standards. It provides tools for managing keys, performing encoding/decoding, and handling cryptographic operations like signing, verification, encryption, and decryption.
It implements the following RFC standards:
- RFC 7515: JSON Web Signature (JWS)
- RFC 7516: JSON Web Encryption (JWE)
- RFC 7517: JSON Web Key (JWK)
- RFC 7518: JSON Web Algorithms (JWA)
- RFC 7519: JSON Web Token (JWT)
- RFC 7520: Examples of Protecting Content Using JOSE
- RFC 7638: JSON Web Key (JWK) Thumbprint